Пропустить навигацию.
Главная

Adobe Flash Player на ubuntu amd64.

Аватар пользователя helios

Продолжаю зеркалить http://halt.pp.ru/

peabody:
Я убедился в одном - ставить 64 битную версию не актуально - не дает ничего полезного, а гимора с софтом не оберешься)) Так что сноси его нафиг и ставь 32 бит версию.

а я ведь в Intro говорил... А проблема, собственно, была в следуйщем: Adobe Flash Player на ubuntu amd64... Вот такакя вот поблема :)

Делаем:
sudo apt-get install nspluginwrapper
читаем дальше :)

Значит, для тех товарищей, которые не сразу хотят расстаться с архитектурой x86_64, а желают ещё немного помучаться © , хитрые программисты придумали такую штуку под названием nspluginwrapper. Поскольку почему-то очень многие самоотверженные пользователи x86_64 на 64-битной машине о нём ничего не знают, то вот кратенькая информация, смысл которой, собственно состоит только в том, чтобы сказать, что под x86_64 МОЖНО поставить и юзать Adobe Flash и другие плагины.
Далее ссылки и информация для слабоговорящих по английски линуксоидов.
Домашняя страница nspluginwrapper:
http://gwenole.beauchesne.info/projects/nspluginwrapper/
Установить его можно или через менеджер пакетов, специфический для вашего дистрибутива, либо как обычно, скачав сырцы с офф. сайта. (Начинающим линуксоидам, не знающим, как ставить программы из исходников -- сюда:
Установка программ из исходников )
Далее идём и скачиваем с офф. сайтов нужные нам плагины. Если вы не знаете, где их искать, то вот на этой страничке перечислены все работающие плагины для x86_64 и места, откуда их нужно брать:
http://plugindoc.mozdev.org/linux-amd64.html
Установка на примере Adobe Flash Player.
Скачиваем Adobe Flash Player Installer.
Распаковываем его.
Делаем в консоли под юзером:
nspluginwrapper -i ~/install_flash_player_9_linux/libflashplayer.so
Всё.
Точно также ставятся другие нужные плагины. Прописывать нужно путь до файлов с расширением .so.
Апгрейд всех установленных в системе и у юзера плагинов:
nspluginwrapper -v -a -u
Удаление плагинов:
nspluginwrapper -r ~/install_flash_player_9_linux/libflashplayer.so
все работает...